close

Home

Exchange Server

Microsoft Warns of Active Exchange Server Exploits, Patches Released

Author avatar - Brad Sams

Brad Sams

|

If you are running an on-premises version of Microsoft Exchange Server, you need to patch your system immediately. Microsoft has announced that they have detected multiple active 0-day exploits being used against the software.

In the announcement post, Microsoft identifies the vulnerabilities that are being exploited as CVE-2021-26855, CVE-2021-26857, CVE-2021-26858, and CVE-2021-27065 – all of these exposure vectors have been patched with the updates that were released yesturday.

advertisment

Microsoft notes that the entity using these exploits, HAFNIUM, is targeting entities in the United States across a wide variety of industries including infectious disease researchers, law firms, higher education institutions, defense contractors, policy think tanks, and NGOs. Based on the company’s detective work, it reads more like if you have an active Exchange server running in your environment, you could likely be a target for attack.

Here are a few more details about the attacks, via Microsoft:

  • CVE-2021-26855 is a server-side request forgery (SSRF) vulnerability in Exchange that allowed the attacker to send arbitrary HTTP requests and authenticate as the Exchange server.
  • CVE-2021-26857 is an insecure deserialization vulnerability in the Unified Messaging service. Insecure deserialization is where untrusted user-controllable data is deserialized by a program. Exploiting this vulnerability gave HAFNIUM the ability to run code as SYSTEM on the Exchange server. This requires administrator permission or another vulnerability to exploit.
  • CVE-2021-26858 is a post-authentication arbitrary file write vulnerability in Exchange. If HAFNIUM could authenticate with the Exchange server then they could use this vulnerability to write a file to any path on the server. They could authenticate by exploiting the CVE-2021-26855 SSRF vulnerability or by compromising a legitimate admin’s credentials.
  • CVE-2021-27065 is a post-authentication arbitrary file write vulnerability in Exchange. If HAFNIUM could authenticate with the Exchange server then they could use this vulnerability to write a file to any path on the server. They could authenticate by exploiting the CVE-2021-26855 SSRF vulnerability or by compromising a legitimate admin’s credentials.

If you think you may be been attacked or want to research if your system has been compromised, Microsoft has provided PowerShell scripts that can identify entries in your log files to understand if you were targeted by HAFNIUM.

I know that many IT Pros do not always patch on the day of a release to make sure there are not any hiccups in the release that could cause additional headaches. But with this release, it is a known active exploit and it is in your best interest to determine quickly if you were targeted and to also patch the exploit.

advertisment

Article saved!

Access saved content from your profile page. View Saved